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OVERVIEW
The Introduction to QuickTest Professional 8.0 
Self-Paced Training focuses on the basic features 
and functions used in creating automated tests 
using QuickTest Professional.
 
This course is intended for all new users of 
QuickTest Professional, those who have had lim-
ited use of the tool from tutorials and testers who 
have no programming background.

Upon completion of this training you should be 
able to demonstrate a basic level of product pro-
ficiency.



QUICKTEST PROFESSIONAL Self-Paced Training

Intended Audience: Non-technical and new users of QuickTest, who need to automate manual 
testing and verification in a short amount of time.

Prerequisites: - Knowledge of HTML
- Working knowledge of Windows applications, Web sites, browsers and 

testing

Software Prerequisites:
■ QuickTest Professional 
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Planning Your Test

Objectives

This chapter contains two exercises:

• Evaluating a Test Case

• Learning the Application Under Test
1-1



 Planning Your Test
 Exercise: Evaluating a Test Case

In this exercise you will test your understanding of a useful test case. First, read Test 
Case 1, then answer the questions in Test Case 1 Review.

Test Case 1

Test Name: InsertOrder

Test Objective: Create a new order with the Flight Reservation application.

Description: Test the functionality of the process to create a new flight reservation.

Application: \QTP\samples\flight\app\flight4a.exe

Windows Versions: Windows 2000 or Windows NT

Test Requirements:

1. Verify that “Insert Done...” appears in the status bar of the Flight Reservation window. 

2. Verify that an order number is displayed in the Order No box of the Flight Reservation 
window. 

3. Verify that the application accepts different combinations of from and to cities.

4. Verify the state of the check boxes in the Open Order window.

■ Initial conditions: all enabled.

■ When Customer Name or Flight Date is checked: Order No. is disabled; the other 
2 are enabled.

■ When Order No. is checked: Order No. is enable; the other 2 are disabled.

5. Verify that “10” is the maximum number of tickets accepted for a flight reservation.

6. After clearing the window of all data, verify that the order just created can be opened and 
displayed in the Flight Reservation window.
Exercise: Evaluating a Test Case1-2



Planning Your Test
 Test Case 1 Review 
1. These are some characteristics of a useful test case. Are these characteristics 

included in Test Case 1? If yes, fill in the answers; if no, write “not included”.

Purpose ____________________________________________

Navigation __________________________________________

Verification __________________________________________

Sample Data _________________________________________

2. List one example of a test objective and two examples of a test requirement.
______________________________________________________

______________________________________________________

______________________________________________________

3. What is the importance of learning the application under test before creating 
automated test scripts?
______________________________________________________

______________________________________________________

______________________________________________________
Test Case 1 Review 1-3
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 Test Case 1 Review Answers

1. Are these characteristics included in the sample Test Case?

Purpose: Test objective stated.

Navigation: User actions are not included.

Verification: Test requirements listed.

Sample Data: Sample data was not included.

2. List one example of a test objective and two examples of a test requirement.

Objective: Create a new order with the flight reservation application.

Requirement: Verify that insert done appears in the status bar of the flight 
reservation window.

Requirement: Verify that an order number is displayed in the order number box on 
the flight reservation window.

3. You can record a basic test with the correct user actions in a short amount of time.
Test Case 1 Review Answers1-4



Planning Your Test
 Exercise: Learning the AUT
Before you can create an effective automated test, you need to learn the application 
under test: Mercury Flight Reservations. 

In this exercise, you will launch Mercury Flight Reservations and perform a simple 
exercise. Taking the time to do this now will help you feel comfortable creating 
automated tests in subsequent chapters.

Part 1: Create a New Order

1. From the START menu, select PROGRAMS > QUICKTEST PROFESSIONAL > 
SAMPLE APPLICATIONS > FLIGHT. The login screen appears.

2. Log in using the AGENT NAME: jojo with a PASSWORD: mercury.

3. Click OK. The application will launch the FLIGHT RESERVATION window as show 
in Figure 1-1.

Figure 1-1  
Exercise: Learning the AUT 1-5



 Planning Your Test
4. Enter the following data in the flight reservation fields: date of travel 11/01/10, 
flying from Paris to San Francisco.

5. Click the FLIGHTS button to display the flight schedule.

6. The first flight on the schedule is highlighted. Click OK to accept this flight and 
close the flight schedule window.

7. In the NAME field, type your name.

8. In the Class field, choose BUSINESS.

9. Click INSERT ORDER. Notice how the application processes your reservation and 
displays an INSERT DONE message when the function is completed.

10. Your order number should appear in the bottom right corner of the FLIGHT 
RESERVATION window. Write the order number assigned to your reservation in this 
space:_______________.
Exercise: Learning the AUT1-6



Planning Your Test
Part 2: Retrieve an Order

1. From the FILE menu, select OPEN > ORDER. The OPEN ORDER screen appears.

2. Put a check in the ORDER NO. field then type your order number.

3. Click OK. Your order appears on your screen. 

4. Change the date of travel to tomorrow’s date.

5. Click UPDATE ORDER. 

Notice how the application processes your update and displays an UPDATE DONE 
message when the function is completed This is illustrated in Figure 1-2.

Figure 1-2  
Exercise: Learning the AUT 1-7
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Part 3: Delete an Order

1. If your flight reservation order is not displayed on your screen, reopen it from the 
FILE menu, enter your order number and click OK. Your order will appear on your 
screen. 

2. Click the DELETE ORDER button. 

3. When the delete confirmation message appears, (Figure 1-3) click YES. Your order 
is now removed from the database.

Figure 1-3  
Exercise: Learning the AUT1-8
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Recording and Running a Test

Objectives

This chapter contains one exercise with four parts:

• Record and Playback

– Set-up the test environment.

– Record a test.

– Run a test.

– Review the test results.
Recording and Running a Test 2-1



 Recording and Running a Test
 Exercise: Record and Playback
In this exercise, you will create a basic test by recording user actions specified in the 
Mercury Flight Reservation test case. The test should run without any errors.

Remember that QuickTest must be opened before you launch the Mercury Flight 
Reservation application. This allows QuickTest to establish internal hooks that will 
capture user actions from the application under test.

Part 1: Set-up the Test Environment

1. Open QuickTest Professional from the START menu. The ADD-IN MANAGER 
appears.

2. Deselect any add-ins that appear in the ADD-IN MANAGER. There are no add-ins 
required for creating test cases during these training exercises.

3. Click OK. QuickTest Professional launch windows open on your screen.

Note: If the QuickTest WELCOME window appears, deselect the option to ALWAYS 
SHOW ON START UP. 

4. Open the Mercury Flight Reservation application. The login window appears. 

5. In the AGENT NAME field type: jojo. In the PASSWORD field type: mercury. The 
Mercury Flight Reservation launch windows open on your screen.

6. Re-open QuickTest Professional then click FILE > NEW TEST from the QuickTest 
menubar.
Exercise: Record and Playback2-2
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7. Click RECORD. The RECORD AND RUN SETTINGS window opens (Figure 2-1).

8. Note: Additional environment tabs will appear in this dialog depending on which 
Add-ins you have loaded. In the example below the Web tab is available because 
the Web Add-in has been loaded.

Figure 2-1  

9. From the WINDOWS APPLICATIONS tab select RECORD AND RUN TEST ON ANY 
OPEN WINDOWS APPLICATION. 

10. Click OK to return to the main QuickTest window.
Recording and Running a Test 2-3
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Part 2: Record the Test

1. Begin recording user actions by re-displaying the flight reservation screen. (You 
may need to click the Flight icon on your windows taskbar). Notice that the word 
RECORDING flashes in red at the bottom right side of the screen as shown in 
Figure 2-2.

Figure 2-2  

2. Record the user actions that will create a new flight reservation. Make up your own 
data or use the following information: date of travel 12/12/09, flying from Frankfurt 
to London.
Exercise: Record and Playback2-4
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3. Click the FLIGHTS button and accept the first flight on the schedule. Click OK.

4. Type your name in the NAME field and choose FIRST class.

5. Click INSERT ORDER. Watch to ensure that the message INSERT DONE...appears in 
the progress bar on the flight reservation screen.

6. Click NEW ORDER button.

Note: Clicking the NEW ORDER button at this step ensures that the screen appears 
exactly as it did at the start of the test. This is referred to as resetting the end condition to 
match the initial condition of the test.

7. From the QuickTest menu, click STOP to end the test.

8. Click FILE > SAVE to store your test as <your initials>_CreateOrder.
Recording and Running a Test 2-5
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Part 3: Run the Test

1. If the test created in Part 2: Record the Test is not already displayed on your screen, 
find and open it by clicking FILE > OPEN TEST from the QuickTest menu bar.

2. Click RUN. In the RUN RESULTS location tab, (Figure 3.) choose the option to save 
your test results to a temporary file. Click OK to close the window.

.

Figure 2-3  

3. Open the Mercury Flight Reservations application. The test should automatically 
begin repeating the actions you recorded earlier.
Exercise: Record and Playback2-6



Recording and Running a Test
4. When the test run is complete, the test results will appear on your screen 
(Figure 2-4).

Figure 2-4  

Note: If the RESULTS SUMMARY window is not automatically displayed when the test 
run ends, click TEST > RESULTS from the menu bar. 
Recording and Running a Test 2-7
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 Test Results Review
Click TEST > RESULTS to see a summary of your test run. 

1. How many times did your test run?

_______________________________________________________________

2. Did your test succeed or fail?

_______________________________________________________________

3. Write the command to display all of the steps in the icon view of the test results.

_______________________________________________________________

Close the TEST RESULTS window. The main QuickTest window appears.

4. Click once on the AGENT NAME step in the KEYWORD VIEW. What field is 
highlighted in the ACTIVE SCREEN view?

_______________________________________________________________

5. Click once on the FLY TO: step in the KEYWORD VIEW. What happened in the 
ACTIVE SCREEN when you selected this step?

_______________________________________________________________
Test Results Review2-8
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 Test Results Review Answers
1. How many times did your test run?

The test ran one time as indicated by the number of iterations in the summary.

2. Did your test succeed or fail?

The test was designed to succeed. If your test failed, try repeating the steps listed in 
the lab exercise. __________________________________________________

3. Write the command to display all of the steps in the icon view of the test results.

VIEW > EXPAND ALL _____________________________________________

Close the TEST RESULTS window. The main QuickTest window appears.

4. Click once on the AGENT NAME step in the KEYWORD VIEW. What field is 
highlighted in the ACTIVE SCREEN view?

The Agent Name field is highlighted. _________________________________

5. Click once on the PASSWORD step in the KEYWORD VIEW. What happened in the 
ACTIVE SCREEN when you selected this step?

The same screen appears but the Password field is now highlighted. _________
Recording and Running a Test 2-9
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Test Results Review Answers2-10
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in QuickTest

Objectives

This chapter contains three exercises:

• Understanding objects

• Identifying objects

– Create a new reservation

– Investigate the objects that are recorded by QuickTest. 

• Using the Object Repository

– Use the object repository to change the default logical name given to an object.
3-1



 Understanding Objects in QuickTest
 Understanding Objects Review
Answer the following questions to test your understanding of the ways that QuickTest 
uses objects to record and playback automated tests. 

1. Circle each item on this list that represents an object class.

a) Test

b) Data entry

c) Drop-down List 

d) Error message

2. The only way to distinguish one object from the other of the same class is by the 
difference in object characteristics. 

TRUE                        FALSE

3. After learning the class and properties of an object, QTP assigns a name to the 
object that is referred to as the:

a) logical name

b) object class

c) object property

d) value

4. QuickTest Professional stores recorded object properties in the: 

a) Object Spy

b) Object Repository

c) Property Value

d) Test Results
Understanding Objects Review3-2



Understanding Objects in QuickTest
 Understanding Objects Review Answers
1. The correct answer is Drop-down list. An object is a graphic user element in an 

application, such as a button or a list or an edit box.

2. The correct answer is True. Specific characteristics of an object within QuickTest 
are called object properties.

3. After learning the class and properties of an object, QTP assigns a name to the 
object. This is known as the object’s logical name.

4. Recorded object properties are stored in QTP’s Object Repository.
Understanding Objects Review Answers 3-3



 Understanding Objects in QuickTest
 Exercise: Identifying Objects
In this exercise, you will create a new test and then investigate the objects that are 
recorded by QuickTest.

Part 1: Create a new test

1. Open QuickTest Professional.

2. Open the Mercury Flight application. START→ PROGRAMS→ QUICKTEST 
PROFESSIONAL→ SAMPLE APPLICATION→ FLIGHT

3. Login using the following information: Agent Name: jojo Password: mercury. The 
Flight Reservation window should appear on your screen.

4. From the QuickTest toolbar, click the Record button . The RECORD 
AND RUN SETTINGS window should open. If it does not open automatically, select 
TEST→ RECORD AND RUN SETTINGS.

5. Choose RECORD ON ANY OPEN WINDOWS-BASED APPLICATION then click OK. 
RECORDING appears in red in the lower right of the QuickTest window.

6. Re-display the Flight Reservation window (minimized in your taskbar) and enter 
the following flight data: Date: 11-11-09, Flying from Denver to Seattle.

7. Click on the FLIGHT button then click OK to accept the first flight schedule.

8. Enter the following personal data: Name: Sam Smith, No. of Tickets: 2, Seating: 
First Class.

9. Click INSERT ORDER. 

10. When INSERT DONE...appears in the progress bar, click the NEW ORDER button 
to clear the data from the flight reservations window. This action also resets 

the original test conditions.

11. Click STOP to end the test.
Exercise: Identifying Objects3-4



Understanding Objects in QuickTest
Part 2: Save the Test

1. Choose FILE >SAVE.

2. Save the test as <your initials>_ObjectReview.

3. Click SAVE. As shown in Figure 3-1, the name of the test now appears in the title of 
the QuickTest window.

Figure 3-1  
Exercise: Identifying Objects 3-5



Part 3: Run the Test

1. From the QuickTest menu bar, click .

2. Click OK to use the TEMPORARY TEST RESULTS directory for this test run.

3. Observe playback of the test.

4. This test was designed to succeed. If your test fails, open the TEST RESULTS to 
analyze and resolve the problem. 

Figure 3-2  
Exercise: Identifying Objects 3-6
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 Test Objects Review
Open the object repository from the main QuickTest window by selecting TOOLS→ 
OBJECT REPOSITORY and answer the following questions:

1. How many objects can you identify?

_______________________________________________________________

2. How many different classes of objects can you identify?

_______________________________________________________________

3. How many objects of the class BUTTON are shown?

_______________________________________________________________
Test Objects Review 3-7
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 Test Objects Review Answers
How many objects can you identify?

10 - Flight reservation, date of flight, tickets, name, flyfrom, flyto, insert order, 
flight, button, flights table.

4. How many different classes of objects can you identify?

7 - window, winbutton, winobject, winedit, winobject, wincombobox, and dialog.

5. How many objects of the class BUTTON are shown?

4 - insert order, flight, button, and OK.
Test Objects Review Answers3-8



Understanding Objects in QuickTest
 Exercise: Changing the Object Name
In this exercise, you will change the logical name that QuickTest assigned to an object in 
your test. Although this concept was not specifically covered in the CBT, you should be 
able to follow the detailed steps in this exercise for a successful result.

Begin by opening the test you created in “Part 1: Create a new test” on page 4. 

1. In the KEYWORD VIEW, use your mouse to highlight the last step in the test as 
shown in Figure 3-3.

Figure 3-3  

2. Notice that the name of the object is BUTTON and the documentation column 
describes the action as CLICK THE “BUTTON” BUTTON. To assign a more descriptive 
name, right-click to open the step menu.

3. Select OBJECT PROPERTIES from the step menu.

4. Click the REPOSITORY button on the OBJECT PROPERTIES window.
Exercise: Changing the Object Name 3-9
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5. Right-click on the BUTTON object to open the menu (Figure 3-4).

Figure 3-4  

6. Type a new name that describes the button such as “New Order”.

7. Click ENTER or click OK twice to save the change and close the object repository 
window.

The new button name should appear in the ITEM column and the DOCUMENTATION 
column in the KEYWORD VIEW as shown in Figure 3-5. 

Figure 3-5  
Exercise: Changing the Object Name3-10
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Creating Synchronization

Steps

Objectives

This chapter contains three exercises:

• Synchronization Review

• Analyzing a Failed Test

• Inserting a Synchronization Point
4-1
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 Synchronization Review
Answer the following questions to test your understanding of the ways that QuickTest 
uses synchronization steps for automated tests. 

1. Circle each function that synchronization performs in a test.

– Updates test data.

– Provides time for an object to process before moving on to the next step.

– Provides time for an environment variable to run.

– Sets an environment variable for an object.

2. Synchronization is enabled only during recording.

TRUE                        FALSE

3. Write the command to insert a synchronization point in a test.

_______________________________________________________________
Synchronization Review4-2



Creating Synchronization Steps
4. Circle each application object that might require synchronization.

– Window frame

– Edit box

– Insert button

– Popup message

5. Open the test called “SYNCH_EXAMPLE” from the directory “Ch04_synch_example” 
in “C:\MTesting”. Note: You created the “C:\MTesting” directory when following 
the steps in the SetupInstructions document. Review the test and write the name of 
the step that represents the synchronization point.

_______________________________________________________________
Synchronization Review 4-3



 Creating Synchronization Steps
 Synchronization Review Answers
1. Circle each function that synchronization performs in a test. 

The correct answer is: Provides time for an object to process before moving on to 
the next step.

2. Synchronization is enabled only during recording.

The correct answer is - TRUE.

3. Write the command to insert a synchronization point in a test.

Insert > Step > Synchronization Point _________________________________

4. Circle each application object that might require synchronization.

The correct answer is: Insert Button and Popup Message.

5. The synchronization point in the SYNCH_EXAMPLE test is named INSERT DONE 
TEXT (Figure 4-1).

Figure 4-1  
Synchronization Review Answers4-4



Creating Synchronization Steps
 Exercise: Analyzing a Failed Test
In this exercise you will observe a failed test by changing the default time-out setting. 

1. From QuickTest Professional, open the test called Create_Order.

2. Launch the Flight Reservation application but do not log in. This test begins with a 
log in script.

3. Click RUN to playback the test. 

4. Save the test results to a temporary directory.

5. Review the test summary by clicking TEST > RESULTS. The test should have 
succeeded without any errors. 

6. Close the TEST RESULTS window. The Create_Order test should be displayed on 
your screen.

7. Click TEST > SETTINGS to open the TEST SETTINGS window.

8. Click the RUN tab and change the OBJECT SYNCHRONIZATION TIMEOUT value from 
20000 to 5000 milliseconds as shown in Figure 4-2. This tells QuickTest to wait 
just 5 seconds before continuing to the next step in the test.

Figure 4-2  
Exercise: Analyzing a Failed Test 4-5



9. Run the test again. The test should have failed because the objects in the application 
were not ready when QuickTest arrived at that point. For example, Figure 4-3 
illustrates the error message that was generated when QuickTest tried to execute the 
File > Exit command before the Insert Order command was completed.

Figure 4-3  

What would you do to correct this problem? One solution would be to reset the timeout 
value to 20000. However, if you know that your application has points that will require 
synchronization, you can record this in the basic test by inserting a synchronization 
point.
Exercise: Analyzing a Failed Test 4-6
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 Exercise: Inserting a Synchronization Point
In this exercise you will create a new test with a synchronization requirement by 
recording user actions from the Mercury Flights application. 

1. Open QuickTest Professional.

2. Open the Mercury Flight Reservation application.

3. Log in to the Flight Reservation application as Agent Name: jojo Password: 
mercury. The Flight Reservation window should be displayed with no data entered.

4. Click RECORD to start the test. Record user actions to create a new flight 
reservation. Make up your own data or use the following information: date of travel 
02/12/10, flying from Denver to Los Angeles.

5. Click the FLIGHTS button and accept the first flight on the schedule. Click OK.

6. Type your name in the NAME field and choose FIRST class.

7. Click INSERT ORDER. At this point, you want to make sure QuickTest waits for the 
order to process completely before moving to the next step in the test. The visual 
cue that the order has processed completely appears in the progress bar 
(Figure 4-4).

Figure 4-4  
Exercise: Inserting a Synchronization Point 4-7
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8. From the QTP menu bar, select INSERT >STEP > SYNCHRONIZATION POINT. The 
cursor becomes a pointed finger. 

9. Click on the words “INSERT DONE...” in the progress bar with the pointed finger.

10. In the OBJECT SELECTION-SYNCHRONIZATION POINT window, click OK. The ADD 
SYNCHRONIZATION POINT window opens (Figure 4-5).

Figure 4-5  

11. Type the word: text in the PROPERTY VALUE field. Keep the default timeout of 
10000 milliseconds.

12. Click OK to close the synchronization window.

13. Finish the test by selecting FILE > NEW ORDER to reset the initial condition.

14. Click RUN to replay your test.

15. View the test results to ensure that your test was executed successfully.
Exercise: Inserting a Synchronization Point4-8
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Using Standard

Checkpoints

Objectives

This chapter contains three exercises:

• Checkpoint Review

• Add a Standard Checkpoint 

• Analyze Test Results
5-1
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 Checkpoints Review
1. What is the function of a checkpoint in QuickTest?

_______________________________________________________________

2. Where is the status of a checkpoint (passed or failed) located?

_______________________________________________________________

3. What causes a checkpoint to fail?

_______________________________________________________________
Checkpoints Review5-2
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 Checkpoints Review Answers
1. A checkpoint is a specialized step in QuickTest that compares two values and 

reports the result.

2. The status of a checkpoint (passed or failed) is located in the Test Results 
Summary.

3. If the two values match, the checkpoint passes; if not, the checkpoint fails.
Checkpoints Review Answers 5-3
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 Exercise: Add a Standard Checkpoint
In this exercise you will create a basic test with one exception - in this test you will insert 
a standard checkpoint during the recording phase. 

Part 1: Create a New Test and Checkpoint

1. Open QuickTest Professional.

2. Open the Mercury Flight application. START→ PROGRAMS→ QUICKTEST 
PROFESSIONAL→ SAMPLE APPLICATION→ FLIGHT

3. Login using the following information: Agent Name: jojo Password: mercury. The 
Flight Reservation window should appear on your screen with no data entered.

4. Click RECORD to start the test. Record user actions to create a new flight 
reservation. Make up your own data or use the following information: date of travel 
02/09/09, flying from Zurich to Portland.

5. Click the FLIGHTS button then click OK to accept the first flight schedule.

6. Type your name in the NAME field and choose FIRST class.

7. Click INSERT ORDER. Your verification that the order has been inserted correctly is 
when the text INSERT DONE...appears in the progress bar; QuickTest’s verification 
will be a standard checkpoint at this step in the test.

Figure 5-1  
Exercise: Add a Standard Checkpoint5-4
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8. From the QTP menu bar, select INSERT >CHECKPOINT > STANDARD 
CHECKPOINT. The cursor becomes a pointed finger. 

9. Click on the words “INSERT DONE...” in the progress bar with the pointed finger.

10. In the OBJECT SELECTION-CHECKPOINT PROPERTIES window, click OK. The 
CHECKPOINT PROPERTIES window opens (Figure 5-2).

Figure 5-2  

11. The property you want to use as a verification is the text INSERT DONE...Deselect all 
other checkboxes and select the text property. INSERT DONE...should appear in the 
CONSTANT field as shown in Figure 5-2.

12. Click OK to close the CHECKPOINT PROPERTIES window.

13. In the Flight Reservation application, click FILE > NEW ORDER to set the end 
condition of the test to match the conditions that existed when the test began.

14. Stop the test.

15. Save the test.
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 Test Results Review
Run the test. Review the results of the test (TEST > RESULTS) to answer the following 
questions.

1. Did your test pass or fail? Where did you locate this information?

_______________________________________________________________

2. Did your checkpoint pass or fail? Where did you locate this information?

_______________________________________________________________

3. Display the details of your checkpoint step. What command did you use to perform 
this task?

_______________________________________________________________
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 Test Results Review Answers
1. This test was designed to run successfully. The word PASSED should appear in 

green text in the ITERATION RESULTS table as shown in Figure 5-3

Figure 5-3  
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 Using Standard Checkpoints
2. This checkpoint was designed to run successfully. Double-click the checkpoint step 
to display the details as shown in Figure 5-4

Figure 5-4  
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6
Adding Parameters

Objectives

This chapter contains three exercises:

• Parameter Types Review

• Create and Run a Test

– Create a new test

– Analyze the test results

• Add an Output Parameter
6-1



 Adding Parameters
 Parameter Types Review

1. Draw a line to connect the parameter type in the left column to the appropriate 
usage in the right column.

2. A data-driven test performs the following functions: (circle all that apply).

a) Runs multiple test iterations using different input values.

b) Uses a database to create a new test.

c) Connects multiple test runs.

d) Reports new data for a test.

Parameter Type Usage

Random Number Insert a number generated earlier in the test run 
into the ORDER NUMBER field each time the test 
runs.

Data Table - Input Insert a different department code into the 
DEPARTMENT NUMBER field each time the test 
runs.

Environment Insert an action from a business process test in 
Mercury Quality Center.

Data Table - Output Insert a number from 1-10 into the NUMBER OF 
ORDERS field each time the test runs.

Component Insert the server name into the HOST ID field 
each time the test is run.

Table 6-1. 
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3. List the differences between the Design-Time data table and the Run-Time data 
table.

_______________________________________________________________

_______________________________________________________________

_______________________________________________________________
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 Parameter Types Review Answers
1.

2. A data-driven test runs multiple test iterations using different input values.

3. Some differences include:

Parameter Type Usage

Random Number Insert a number from 1-10 into the NUMBER OF 
ORDERS field each time the test runs.

Data Table - Input Insert a different department code into the 
DEPARTMENT NUMBER field each time the test 
runs.

Environment Insert the server name into the HOST ID field 
each time the test is run.

Data Table - Output Insert a number generated earlier in the test run 
into the ORDER NUMBER field each time the test 
runs.

Component Insert an action from a business process test in 
Mercury Quality Center.

Design-Time Data Table: Run Time Data Table:

Viewed in the main 
QuickTest window

Viewed in the Test Results window

Created prior to the 
execution of the test.

Generated after a test is executed.

Represents data from an 
external source.

Represents a “live” version of the Design-Time 
table after the test run.
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 Exercise: Create and Run a Test
In this exercise you will create a basic test that requires parameterization to run 
successfully. 

Part 1: Create a New Test and Checkpoint

1. Open QuickTest Professional.

2. Open the Mercury Flight application. START→ PROGRAMS→ QUICKTEST 
PROFESSIONAL→ SAMPLE APPLICATION→ FLIGHT

3. Login using the following information: Agent Name: jojo Password: mercury. The 
Flight Reservation window should appear on your screen with no data entered.

4. Click RECORD to start the test. Record user actions to create a new flight 
reservation. Make up your own data or use the following information: date of travel 
05/25/11, flying from Frankfurt to Los Angeles.

5. Click the FLIGHTS button then click OK to accept the first flight schedule.

6. Type your name in the NAME field and choose FIRST class.

7. Click INSERT ORDER. Wait until INSERT DONE...appears in the progress bar as 
illustrated in Figure 6-1.

Figure 6-1  
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8. In QuickTest Pro insert a synchronization point on the INSERT ORDER step:

a) In QuickTest Pro select INSERT > STEP > SYNCHRONIZATION POINT. Your 
cursor changes to a pointing hand and the Flights window is redisplayed.

b) Single-click on the INSERT DONE...text in the progress bar on the Flights 
window. The OBJECT SELECTION window opens. 

c) Verify that WINOBJECT: INSERT DONE is selected, then click OK. The ADD 
SYNCHRONIZATION POINT window opens.

d) In the PROPERTY TYPE field, choose TEXT.

e) In the PROPERTY VALUE field, type “Insert Done...” including the quotation 
marks and the dots.

f) Click OK. The INSERT DONE step now appears as a synchronization point in 
your test (Figure 6-2).

Figure 6-2  
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9. Insert a checkpoint to validate the ORDER NUMBER number field:

a) Click INSERT > CHECKPOINT > STANDARD CHECKPOINT. The cursor 
changes to a pointing hand.

b) Single-click on the ORDER NUMBER field on the FLIGHTS window.

c) Make sure that WINEDIT: ORDER NO. is highlighted in the OBJECT 
SELECTION window, then click OK. The Checkpoint properties window opens.

d) Make sure that only the ENABLED field has a checkmark, then click OK. The 
Checkpoint is inserted into the text.

10. In the Windows Mercury Flight Application click FILE > OPEN ORDER.

11. Check the box next to the ORDER NO. field.

12. Type the order number of the reservation you just created. The order should 
reappear on your screen. Click OK.

13. Change the number of tickets from 1 to 2.

14. Click UPDATE ORDER.

15. Click FILE > NEW ORDER to reset the original conditions of the test.

16. Click STOP to end the recording.
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Part 2: Run the Test and Analyze the Error

1. Click RUN. Your test should encounter an error as illustrated in Figure 6-3. 

Figure 6-3  

In order to perform the open order step, the test is searching for an ORDER NO. that was 
deleted when you recorded the test. This order was assigned to the previous reservation 
and does not appear in this test iteration. Instead of searching for a constant order 
number, your test should be using whatever order number is generated and inserted into 
the test iteration.

What should you do to make your test run successfully?

One solution is to create an output parameter that instructs QuickTest to use the order 
number generated by the application under test.
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 Exercise: Create an Output Parameter

Part 1: Capture an Output Value

1. Highlight the step ORDER NUMBER step in the Keyword View. This is the step that 
was created during the checkpoint part of the previous exercise.

2. Move your cursor to the Active Screen (lower right) and right-click on the ORDER 

NO. field

3. Choose INSERT OUTPUT VALUE from the ORDER NO. field menu. The OBJECT 

SELECTION -OUTPUT VALUE PROPERTIES window opens.

4. Make sure that WINEDIT: ORDER NO. is highlighted then click OK. The OUTPUT 

VALUE PROPERTIES window opens.

5. Check the box next to TEXT.

6. Select the radio button for AFTER CURRENT STEP located at the bottom of the 
OUTPUT VALUE PROPERTIES window.

7. Click OK to close the properties window. A column called ORDER_NO_TEXT_OUT 

should appear in the lower left portion of the QuickTest window (Figure 6-5).

Figure 6-4  
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Part 2: Run the Test and Analyze the Error

1. Click RUN. Your test should encounter an error and fail. 

2. Can you determine why your test is continuing to fail?

The test continues to fail because the ORDER NO. window has no value (input). How 
could you fix the problem? The solution is to modify the ORDER NO. field to accept the 
value that was generated and stored in the output parameter data table. This is described 
in “Part 3: Create an Input Parameter” .
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Part 3: Create an Input Parameter

1. Highlight the EDIT step under the parent step titled OPEN ORDER then click once in 
the VALUE column. 

2. Click the parameter icon <#> to open the VALUE CONFIGURATION OPTIONS 
window.

3. Click the PARAMETER radio button and select DATA TABLE from the drop-down 
list. Make sure that the output parameter data table called ORDER NUMBER TEXT 
OUT appears in the NAME field (Figure 6-5).

.

Figure 6-5  

4. Click OK.

5. Save the test as <your initials>_parameter_example.

Part 4: Run the Test and Celebrate your Success

1. Click RUN. Your test should succeed.
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7
Recovery Manager

Objectives

This chapter contains three exercises:

• Recovery Manager Review

• Create a New Test

– Add an input parameter for multiple test iterations

– Analyze the failed test results

• Create a Recovery Scenario

– Add two recovery operations to the test

– Analyze the successful test results
7-1



 Recovery Manager
 Recovery Manager Review

1. List four types of trigger events that would interrupt your test run.

_______________________________________________________________

_______________________________________________________________

_______________________________________________________________

_______________________________________________________________

2. Define the term Recovery Operation.

_______________________________________________________________

_______________________________________________________________

3. List one example of a Post-Recovery Test Run option.

_______________________________________________________________
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 Recovery Manager Review Answers
1. A checkpoint is a specialized step in QuickTest that compares two values and 

reports the result.

2. The status of a checkpoint (passed or failed) is located in the TEST RESULTS 
SUMMARY.

3. A post-recovery test run option is how QuickTest should proceed once the recovery 
operations have been performed, and from which point in the test QuickTest should 
continue, if at all. Examples are: restart a test from the beginning, skip the test step 
entirely and continue with the next step in the test, restart the test, repeat the step 
again.
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 Exercise: Parameterized Test
In this exercise you will create a test to validate multiple login names using a data table 
as a parameter for multiple test iterations. 

Part 1: Create a New Test

1. Open QuickTest Professional.

2. Click RECORD on the QuickTest Professional menu bar.The RECORD AND RUN 
SETTINGS window opens. Choose to record on any open windows application.

3. Open the Mercury Flight application. START→ PROGRAMS→ QUICKTEST 
PROFESSIONAL→ SAMPLE APPLICATION→ FLIGHT. 

4. Login using the following information: Agent Name: jojo Password: mercury. The 
Flight Reservation window should appear on your screen with no data entered.

5. Click FILE > EXIT to close the Flight application. 

6. Click STOP on the QuickTest Professional menu bar.

Save the test as <your initials> login_check. Your test should look like the example in 
Figure 7-1.

Figure 7-1  
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Part 2: Add a Data Table Parameter

1. Highlight the AGENT NAME step then click once in the VALUE column. 

2. Click the parameter icon <#> to open the VALUE CONFIGURATION OPTIONS 
window.

3. Click the PARAMETER radio button and select DATA TABLE from the drop-down 
list. 

4. Type a description for the input parameters, such as Login_Names, in the NAME 
field.

5. Click OK. The heading you created should appear in the first data table column. 

6. Add the following 5 names to your data table: bob32, bob0404, bob, bobsmith, 
bsmith. A similar table is shown in Figure 7-2.

Figure 7-2  

7. Click the SAVE icon to retain the changes to your test.
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 Recovery Manager
 Exercise: Recovery Scenario

Part 1: Create a Recovery Scenario

1. If the test you created is not already displayed on your screen, find and open it by 
clicking FILE > OPEN TEST from the QuickTest menu bar.

2. Click RUN. In the RUN RESULTS location tab, choose the option to save your test 
results to a temporary file. Click OK to close the window.

3. Your test should fail during the third iteration. What error message appeared that 
stopped the test from continuing?

_______________________________________________________________

4. To anticipate and correct this error, click TOOLS > RECOVERY SCENARIO from the 
QuickTest menu bar. The Recovery Manager window opens.

5. Click the NEW SCENARIO WIZARD icon as shown in FIGURE 7-3. The RECOVERY 
SCENARIO WIZARD opens.

.

Figure 7-3  

6. Review the information on the WELCOME screen then click NEXT.
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7. Select the trigger event that caused the error (Pop-up window), then click NEXT.

8. To identify the name of the window where the error message appears, click the 
POINTING HAND icon. The application popup window appears on the screen.

9. Move the POINTING HAND to the application popup error window then click once. 
The name of the window appears in the WINDOW TITLE: field in the Recovery 
Scenario Wizard (Figure 7-4.) 

Figure 7-4  

10. Click NEXT to continue.The RECOVERY screen appears.

11. You do not need to make any additions to this screen. Click NEXT. The RECOVERY 
OPERATION screen appears.

12. Choose the operation type: KEYBOARD OR MOUSE OPERATION. Click NEXT. 

13. Choose the radio button: CLICK BUTTON WITH LABEL:.

14. Click on the pointing hand to activate it.

15. With the pointing hand click on the OK button in the application popup error 
window.
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16. Click NEXT. The RECOVERY OPERATIONS screen opens. 

17. De-select the option to ADD ANOTHER RECOVERY SCENARIO then click NEXT.

18. In the TEST OPTIONS list, choose the PROCEED TO NEXT STEP radio button. This 
enables the test to move to the next step after taking action to resolve the popup 
window error. Click NEXT.

19. Type a name for your scenario. Click NEXT. The FINISH screen opens.

20. Check the box to ADD SCENARIO TO CURRENT TEST. Click FINISH. The name of 
your scenario should now appear in the Recovery Manager window, as shown in 
Figure 7-5.

Figure 7-5  

21. Click the SAVE icon on the Recovery Manager window to store the scenario you 
created as a .qrs file.

22. Click CLOSE. 

23. Stop the test run. 
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Part 2: Run the Test and Analyze the Results

If you analyzed the application error thoroughly, you may already know that a second 
recovery scenario is required to make the test run successfully. 

If you haven’t found the second problem that needs to be resolved, run the test again. 
Even if the test calls the recovery scenario to resolve the popup window, the test still 
fails. 

The second recovery scenario you need to create is the operation to click the CANCEL 
button on the login window. Try this on your own, or use the steps provided in Part 3: 
Create a Second Recovery Scenario
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Part 3: Create a Second Recovery Scenario

1. If the test you created is not already displayed on your screen, find and open it by 
clicking FILE > OPEN TEST from the QuickTest menu bar.

2. Click RUN. In the RUN RESULTS location tab, choose the option to save your test 
results to a temporary file. Click OK to close the window.

3. Your test should fail during the third iteration. What error message appeared that 
stopped the test from continuing?

_______________________________________________________________

4. To anticipate and correct this error, click TOOLS > RECOVERY SCENARIO from the 
QuickTest menu bar. The Recovery Manager window opens.

5. Click the NEW SCENARIO WIZARD icon. Review the information on the WELCOME 
screen then click NEXT.

6. Select the trigger event that caused the error (Popup window), then click NEXT.

7. To identify the name of the window where the error message appears, click the 
POINTING HAND icon. The application popup window appears on the screen.

1. Move the POINTING HAND to the application login window then click once. The 
name of the window appears in the WINDOW TITLE field in the Recovery Scenario 
Wizard. 

2. Click NEXT to continue.The RECOVERY screen appears.
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3. You do not need to make any additions to this screen. Click NEXT. The second 
recovery scenario screen appears.

4. Define the action that QuickTest should take if this error occurs during a test run by 
clicking the POINTING HAND icon. The application window appears on the screen.

5. Move the POINTING HAND to the application window then click once on the 
CANCEL button. The name of the button appears in the CLICK BUTTON WITH LABEL 
field in the Recovery Scenario Wizard. 

6. Click NEXT. The RECOVERY OPERATIONS screen opens. 

7. De-select the option to add another recovery scenario then click NEXT.

8. In the TEST OPTIONS list, choose PROCEED TO THE NEXT STEP. This enables the 
test to move to the next step after taking action to resolve the popup window error. 
Click NEXT.

9. Type a new name for this second scenario. Click NEXT. The FINISH screen opens.

10. Check the box to ADD SCENARIO TO CURRENT TEST. Click FINISH. 

The name of your scenario should now appear in the Recovery Manager window.
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Part 4: Check the Test Settings and Run the Test 

1. To make sure that both scenarios are linked to your test, click TEST > SETTINGS 
from the QuickTest menu bar. The TEST SETTINGS window opens.

2. Click the RECOVERY tab.

3. Check to make sure that two scenarios appear in the Recovery tab as shown in 
Figure 7-6. Use the + or X icons to add or delete a scenario. 

Figure 7-6  

4. Click OK.

5. Click RUN to playback the test. The test should succeed.
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	1 Planning Your Test
	Objectives

	Exercise: Evaluating a Test Case
	Test Case 1

	Test Case 1 Review
	1. These are some characteristics of a useful test case. Are these characteristics included in Te...
	2. List one example of a test objective and two examples of a test requirement.
	3. What is the importance of learning the application under test before creating automated test s...

	Test Case 1 Review Answers
	1. Are these characteristics included in the sample Test Case?
	Purpose: Test objective stated.
	Navigation: User actions are not included.
	Verification: Test requirements listed.
	Sample Data: Sample data was not included.

	2. List one example of a test objective and two examples of a test requirement.
	Objective: Create a new order with the flight reservation application.
	Requirement: Verify that insert done appears in the status bar of the flight reservation window.
	Requirement: Verify that an order number is displayed in the order number box on the flight reser...

	3. You can record a basic test with the correct user actions in a short amount of time.

	Exercise: Learning the AUT
	Part 1: Create a New Order
	1. From the Start menu, select Programs > QuickTest Professional > Sample Applications > Flight. ...
	2. Log in using the Agent Name: jojo with a Password: mercury.
	3. Click OK. The application will launch the Flight Reservation window as show in Figure�1�1.
	Figure 1�1
	4. Enter the following data in the flight reservation fields: date of travel 11/01/10, flying fro...
	5. Click the Flights button to display the flight schedule.
	6. The first flight on the schedule is highlighted. Click OK to accept this flight and close the ...
	7. In the Name field, type your name.
	8. In the Class field, choose Business.
	9. Click Insert Order. Notice how the application processes your reservation and displays an Inse...
	10. Your order number should appear in the bottom right corner of the Flight Reservation window. ...


	Part 2: Retrieve an Order
	1. From the File menu, select Open > Order. The Open Order screen appears.
	2. Put a check in the Order No. field then type your order number.
	3. Click OK. Your order appears on your screen.
	4. Change the date of travel to tomorrow’s date.
	5. Click Update Order.
	Figure 1�2

	Part 3: Delete an Order
	1. If your flight reservation order is not displayed on your screen, reopen it from the File menu...
	2. Click the Delete Order button.
	3. When the delete confirmation message appears, (Figure�1�3) click Yes. Your order is now remove...
	Figure 1�3

	2 Recording and Running a Test
	Objectives


	Exercise: Record and Playback
	Part 1: Set-up the Test Environment
	1. Open QuickTest Professional from the Start menu. The Add-In Manager appears.
	2. Deselect any add-ins that appear in the Add-in Manager. There are no add-ins required for crea...
	3. Click OK. QuickTest Professional launch windows open on your screen.
	4. Open the Mercury Flight Reservation application. The login window appears.
	5. In the Agent Name field type: jojo. In the Password field type: mercury. The Mercury Flight Re...
	6. Re-open QuickTest Professional then click File > New Test from the QuickTest menubar.
	7. Click Record. The Record and Run Settings window opens (Figure�2�1).
	8. Note: Additional environment tabs will appear in this dialog depending on which Add-ins you ha...
	Figure 2�1
	9. From the Windows Applications tab select Record and run test on Any Open Windows application.
	10. Click OK to return to the main QuickTest window.


	Part 2: Record the Test
	1. Begin recording user actions by re-displaying the flight reservation screen. (You may need to ...
	Figure 2�2
	2. Record the user actions that will create a new flight reservation. Make up your own data or us...
	3. Click the Flights button and accept the first flight on the schedule. Click OK.
	4. Type your name in the Name field and choose First class.
	5. Click Insert Order. Watch to ensure that the message Insert Done...appears in the progress bar...
	6. Click New Order button.
	7. From the QuickTest menu, click Stop to end the test.
	8. Click File > Save to store your test as <your initials>_CreateOrder.


	Part 3: Run the Test
	1. If the test created in Part 2: Record the Test is not already displayed on your screen, find a...
	2. Click Run. In the Run Results location tab, (Figure�3.) choose the option to save your test re...
	Figure 2�3
	3. Open the Mercury Flight Reservations application. The test should automatically begin repeatin...
	4. When the test run is complete, the test results will appear on your screen (Figure�2�4).

	Figure 2�4


	Test Results Review
	1. How many times did your test run?
	2. Did your test succeed or fail?
	3. Write the command to display all of the steps in the icon view of the test results.
	4. Click once on the Agent Name step in the Keyword View. What field is highlighted in the Active...
	5. Click once on the Fly To: step in the Keyword View. What happened in the Active Screen when yo...

	Test Results Review Answers
	1. How many times did your test run?
	The test ran one time as indicated by the number of iterations in the summary.
	2. Did your test succeed or fail?
	The test was designed to succeed. If your test failed, try repeating the steps listed in the lab ...

	3. Write the command to display all of the steps in the icon view of the test results.
	View > Expand All

	4. Click once on the Agent Name step in the Keyword View. What field is highlighted in the Active...
	The Agent Name field is highlighted.

	5. Click once on the Password step in the Keyword View. What happened in the Active Screen when y...
	The same screen appears but the Password field is now highlighted.

	3 Understanding Objects in QuickTest
	Objectives


	Understanding Objects Review
	1. Circle each item on this list that represents an object class.
	a) Test
	b) Data entry
	c) Drop-down List
	d) Error message

	2. The only way to distinguish one object from the other of the same class is by the difference i...
	3. After learning the class and properties of an object, QTP assigns a name to the object that is...
	a) logical name
	b) object class
	c) object property
	d) value

	4. QuickTest Professional stores recorded object properties in the:
	a) Object Spy
	b) Object Repository
	c) Property Value
	d) Test Results


	Understanding Objects Review Answers
	1. The correct answer is Drop-down list. An object is a graphic user element in an application, s...
	2. The correct answer is True. Specific characteristics of an object within QuickTest are called ...
	3. After learning the class and properties of an object, QTP assigns a name to the object. This i...
	4. Recorded object properties are stored in QTP’s Object Repository.

	Exercise: Identifying Objects
	Part 1: Create a new test
	1. Open QuickTest Professional.
	2. Open the Mercury Flight application. StartÆ ProgramsÆ QuickTest ProfessionalÆ Sample Applicati...
	3. Login using the following information: Agent Name: jojo Password: mercury. The Flight Reservat...
	4. From the QuickTest toolbar, click the Record button. The Record and Run Settings window should...
	5. Choose Record on any open Windows-based application then click OK. Recording appears in red in...
	6. Re-display the Flight Reservation window (minimized in your taskbar) and enter the following f...
	7. Click on the Flight button then click OK to accept the first flight schedule.
	8. Enter the following personal data: Name: Sam Smith, No. of Tickets: 2, Seating: First Class.
	9. Click Insert Order.
	10. When Insert Done...appears in the progress bar, click the New Order button to clear the data ...
	11. Click Stop to end the test.

	Part 2: Save the Test
	1. Choose File >Save.
	2. Save the test as <your initials>_ObjectReview.
	3. Click Save. As shown in Figure�3�1, the name of the test now appears in the title of the Quick...
	Figure 3�1

	Part 3: Run the Test
	1. From the QuickTest menu bar, click .
	2. Click OK to use the Temporary Test Results directory for this test run.
	3. Observe playback of the test.
	4. This test was designed to succeed. If your test fails, open the Test Results to analyze and re...
	Figure 3�2


	Test Objects Review
	1. How many objects can you identify?
	2. How many different classes of objects can you identify?
	3. How many objects of the class Button are shown?

	Test Objects Review Answers
	10 - Flight reservation, date of flight, tickets, name, flyfrom, flyto, insert order, flight, but...
	4. How many different classes of objects can you identify?
	7 - window, winbutton, winobject, winedit, winobject, wincombobox, and dialog.

	5. How many objects of the class Button are shown?
	4 - insert order, flight, button, and OK.


	Exercise: Changing the Object Name
	1. In the Keyword View, use your mouse to highlight the last step in the test as shown in Figure�...
	Figure 3�3
	2. Notice that the name of the object is Button and the documentation column describes the action...
	3. Select Object Properties from the step menu.
	4. Click the Repository button on the Object Properties window.
	5. Right-click on the Button object to open the menu (Figure�3�4).

	Figure 3�4
	6. Type a new name that describes the button such as “New Order”.
	7. Click Enter or click OK twice to save the change and close the object repository window.

	Figure 3�5
	4 Creating Synchronization Steps
	Objectives


	Synchronization Review
	1. Circle each function that synchronization performs in a test.
	2. Synchronization is enabled only during recording.
	3. Write the command to insert a synchronization point in a test.
	4. Circle each application object that might require synchronization.
	5. Open the test called “synch_example” from the directory “Ch04_synch_example” in “C:\MTesting”....

	Synchronization Review Answers
	1. Circle each function that synchronization performs in a test.
	The correct answer is: Provides time for an object to process before moving on to the next step.
	2. Synchronization is enabled only during recording.
	The correct answer is - TRUE.

	3. Write the command to insert a synchronization point in a test.
	Insert > Step > Synchronization Point

	4. Circle each application object that might require synchronization.
	The correct answer is: Insert Button and Popup Message.

	5. The synchronization point in the Synch_Example test is named Insert Done Text (Figure�4�1).
	Figure 4�1

	Exercise: Analyzing a Failed Test
	1. From QuickTest Professional, open the test called Create_Order.
	2. Launch the Flight Reservation application but do not log in. This test begins with a log in sc...
	3. Click Run to playback the test.
	4. Save the test results to a temporary directory.
	5. Review the test summary by clicking Test > Results. The test should have succeeded without any...
	6. Close the Test Results window. The Create_Order test should be displayed on your screen.
	7. Click Test > Settings to open the Test Settings window.
	8. Click the Run tab and change the Object Synchronization Timeout value from 20000 to 5000 milli...
	Figure 4�2
	9. Run the test again. The test should have failed because the objects in the application were no...

	Figure 4�3

	Exercise: Inserting a Synchronization Point
	1. Open QuickTest Professional.
	2. Open the Mercury Flight Reservation application.
	3. Log in to the Flight Reservation application as Agent Name: jojo Password: mercury. The Flight...
	4. Click Record to start the test. Record user actions to create a new flight reservation. Make u...
	5. Click the Flights button and accept the first flight on the schedule. Click OK.
	6. Type your name in the Name field and choose First class.
	7. Click Insert Order. At this point, you want to make sure QuickTest waits for the order to proc...
	Figure 4�4
	8. From the QTP menu bar, select Insert >Step > Synchronization Point. The cursor becomes a point...
	9. Click on the words “Insert Done...” in the progress bar with the pointed finger.
	10. In the Object Selection-Synchronization Point window, click OK. The Add Synchronization Point...

	Figure 4�5
	11. Type the word: text in the Property Value field. Keep the default timeout of 10000 milliseconds.
	12. Click OK to close the synchronization window.
	13. Finish the test by selecting File > New Order to reset the initial condition.
	14. Click Run to replay your test.
	15. View the test results to ensure that your test was executed successfully.

	5 Using Standard Checkpoints
	Objectives


	Checkpoints Review
	1. What is the function of a checkpoint in QuickTest?
	2. Where is the status of a checkpoint (passed or failed) located?
	3. What causes a checkpoint to fail?

	Checkpoints Review Answers
	1. A checkpoint is a specialized step in QuickTest that compares two values and reports the result.
	2. The status of a checkpoint (passed or failed) is located in the Test Results Summary.
	3. If the two values match, the checkpoint passes; if not, the checkpoint fails.

	Exercise: Add a Standard Checkpoint
	Part 1: Create a New Test and Checkpoint
	1. Open QuickTest Professional.
	2. Open the Mercury Flight application. StartÆ ProgramsÆ QuickTest ProfessionalÆ Sample Applicati...
	3. Login using the following information: Agent Name: jojo Password: mercury. The Flight Reservat...
	4. Click Record to start the test. Record user actions to create a new flight reservation. Make u...
	5. Click the Flights button then click OK to accept the first flight schedule.
	6. Type your name in the Name field and choose First class.
	7. Click Insert Order. Your verification that the order has been inserted correctly is when the t...
	Figure 5�1
	8. From the QTP menu bar, select Insert >Checkpoint > Standard Checkpoint. The cursor becomes a p...
	9. Click on the words “Insert Done...” in the progress bar with the pointed finger.
	10. In the Object Selection-Checkpoint Properties window, click OK. The Checkpoint Properties win...

	Figure 5�2
	11. The property you want to use as a verification is the text Insert Done...Deselect all other c...
	12. Click OK to close the Checkpoint Properties window.
	13. In the Flight Reservation application, click File > New Order to set the end condition of the...
	14. Stop the test.
	15. Save the test.



	Test Results Review
	1. Did your test pass or fail? Where did you locate this information?
	2. Did your checkpoint pass or fail? Where did you locate this information?
	3. Display the details of your checkpoint step. What command did you use to perform this task?

	Test Results Review Answers
	1. This test was designed to run successfully. The word Passed should appear in green text in the...
	Figure 5�3
	2. This checkpoint was designed to run successfully. Double-click the checkpoint step to display ...

	Figure 5�4
	6 Adding Parameters
	Objectives


	Parameter Types Review
	1. Draw a line to connect the parameter type in the left column to the appropriate usage in the r...
	Parameter Type
	Usage
	Random Number
	Insert a number generated earlier in the test run into the Order Number field each time the test ...
	Data Table - Input
	Insert a different department code into the Department Number field each time the test runs.
	Environment
	Insert an action from a business process test in Mercury Quality Center.
	Data Table - Output
	Insert a number from 1-10 into the Number of Orders field each time the test runs.
	Component
	Insert the server name into the Host ID field each time the test is run.
	Table 6�1.
	2. A data-driven test performs the following functions: (circle all that apply).
	a) Runs multiple test iterations using different input values.
	b) Uses a database to create a new test.
	c) Connects multiple test runs.
	d) Reports new data for a test.

	3. List the differences between the Design-Time data table and the Run-Time data table.



	Parameter Types Review Answers
	1.
	Parameter Type
	Usage
	Random Number
	Insert a number from 1-10 into the Number of Orders field each time the test runs.
	Data Table - Input
	Insert a different department code into the Department Number field each time the test runs.
	Environment
	Insert the server name into the Host ID field each time the test is run.
	Data Table - Output
	Insert a number generated earlier in the test run into the Order Number field each time the test ...
	Component
	Insert an action from a business process test in Mercury Quality Center.
	2. A data-driven test runs multiple test iterations using different input values.
	3. Some differences include:


	Design-Time Data Table:
	Run Time Data Table:
	Viewed in the main QuickTest window
	Viewed in the Test Results window
	Created prior to the execution of the test.
	Generated after a test is executed.
	Represents data from an external source.
	Represents a “live” version of the Design-Time table after the test run.


	Exercise: Create and Run a Test
	Part 1: Create a New Test and Checkpoint
	1. Open QuickTest Professional.
	2. Open the Mercury Flight application. StartÆ ProgramsÆ QuickTest ProfessionalÆ Sample Applicati...
	3. Login using the following information: Agent Name: jojo Password: mercury. The Flight Reservat...
	4. Click Record to start the test. Record user actions to create a new flight reservation. Make u...
	5. Click the Flights button then click OK to accept the first flight schedule.
	6. Type your name in the Name field and choose First class.
	7. Click Insert Order. Wait until Insert Done...appears in the progress bar as illustrated in Fig...
	Figure 6�1
	8. In QuickTest Pro insert a synchronization point on the Insert Order step:
	a) In QuickTest Pro select Insert > Step > Synchronization Point. Your cursor changes to a pointi...
	b) Single-click on the Insert Done...text in the progress bar on the Flights window. The Object S...
	c) Verify that WinObject: Insert Done is selected, then click OK. The Add Synchronization Point w...
	d) In the Property Type field, choose text.
	e) In the Property Value field, type “Insert Done...” including the quotation marks and the dots.
	f) Click OK. The Insert Done step now appears as a synchronization point in your test (Figure�6�2).


	Figure 6�2
	9. Insert a checkpoint to validate the Order Number number field:
	a) Click Insert > Checkpoint > Standard Checkpoint. The cursor changes to a pointing hand.
	b) Single-click on the Order Number field on the Flights window.
	c) Make sure that WinEdit: Order No. is highlighted in the Object Selection window, then click OK...
	d) Make sure that only the Enabled field has a checkmark, then click OK. The Checkpoint is insert...

	10. In the Windows Mercury Flight Application click File > Open Order.
	11. Check the box next to the Order No. field.
	12. Type the order number of the reservation you just created. The order should reappear on your ...
	13. Change the number of tickets from 1 to 2.
	14. Click Update Order.
	15. Click File > New Order to reset the original conditions of the test.
	16. Click Stop to end the recording.


	Part 2: Run the Test and Analyze the Error
	1. Click Run. Your test should encounter an error as illustrated in Figure�6�3.
	Figure 6�3


	Exercise: Create an Output Parameter
	Part 1: Capture an Output Value
	1. Highlight the step Order Number step in the Keyword View. This is the step that was created du...
	2. Move your cursor to the Active Screen (lower right) and right-click on the ORDER NO. field
	3. Choose INSERT OUTPUT VALUE from the ORDER NO. field menu. The OBJECT SELECTION -OUTPUT VALUE P...
	4. Make sure that WINEDIT: ORDER NO. is highlighted then click OK. The OUTPUT VALUE PROPERTIES wi...
	5. Check the box next to TEXT.
	6. Select the radio button for AFTER CURRENT STEP located at the bottom of the OUTPUT VALUE PROPE...
	7. Click OK to close the properties window. A column called ORDER_NO_TEXT_OUT should appear in th...
	Figure 6�4

	Part 2: Run the Test and Analyze the Error
	1. Click Run. Your test should encounter an error and fail.
	2. Can you determine why your test is continuing to fail?

	Part 3: Create an Input Parameter
	1. Highlight the Edit step under the parent step titled Open Order then click once in the Value c...
	2. Click the parameter icon <#> to open the Value Configuration Options window.
	3. Click the Parameter radio button and select Data Table from the drop-down list. Make sure that...
	Figure 6�5
	4. Click OK.
	5. Save the test as <your initials>_parameter_example.


	Part 4: Run the Test and Celebrate your Success
	1. Click Run. Your test should succeed.

	7 Recovery Manager
	Objectives


	Recovery Manager Review
	1. List four types of trigger events that would interrupt your test run.
	2. Define the term Recovery Operation.
	3. List one example of a Post-Recovery Test Run option.

	Recovery Manager Review Answers
	1. A checkpoint is a specialized step in QuickTest that compares two values and reports the result.
	2. The status of a checkpoint (passed or failed) is located in the Test Results Summary.
	3. A post-recovery test run option is how QuickTest should proceed once the recovery operations h...

	Exercise: Parameterized Test
	Part 1: Create a New Test
	1. Open QuickTest Professional.
	2. Click Record on the QuickTest Professional menu bar.The Record and Run Settings window opens. ...
	3. Open the Mercury Flight application. StartÆ ProgramsÆ QuickTest ProfessionalÆ Sample Applicati...
	4. Login using the following information: Agent Name: jojo Password: mercury. The Flight Reservat...
	5. Click File > Exit to close the Flight application.
	6. Click Stop on the QuickTest Professional menu bar.
	Figure 7�1

	Part 2: Add a Data Table Parameter
	1. Highlight the Agent Name step then click once in the Value column.
	2. Click the parameter icon <#> to open the Value Configuration Options window.
	3. Click the Parameter radio button and select Data Table from the drop-down list.
	4. Type a description for the input parameters, such as Login_Names, in the Name field.
	5. Click OK. The heading you created should appear in the first data table column.
	6. Add the following 5 names to your data table: bob32, bob0404, bob, bobsmith, bsmith. A similar...
	Figure 7�2
	7. Click the Save icon to retain the changes to your test.



	Exercise: Recovery Scenario
	Part 1: Create a Recovery Scenario
	1. If the test you created is not already displayed on your screen, find and open it by clicking ...
	2. Click Run. In the Run Results location tab, choose the option to save your test results to a t...
	3. Your test should fail during the third iteration. What error message appeared that stopped the...
	4. To anticipate and correct this error, click Tools > Recovery Scenario from the QuickTest menu ...
	5. Click the New Scenario wizard icon as shown in Figure�7�3. The Recovery scenario wizard opens.
	Figure 7�3
	6. Review the information on the Welcome screen then click Next.
	7. Select the trigger event that caused the error (Pop-up window), then click Next.
	8. To identify the name of the window where the error message appears, click the Pointing Hand ic...
	9. Move the Pointing Hand to the application popup error window then click once. The name of the ...

	Figure 7�4
	10. Click Next to continue.The Recovery screen appears.
	11. You do not need to make any additions to this screen. Click Next. The Recovery Operation scre...
	12. Choose the operation type: Keyboard or mouse operation. Click Next.
	13. Choose the radio button: Click button with label:.
	14. Click on the pointing hand to activate it.
	15. With the pointing hand click on the OK button in the application popup error window.
	16. Click Next. The Recovery Operations screen opens.
	17. De-select the option to Add another recovery scenario then click Next.
	18. In the Test Options list, choose the Proceed to next step radio button. This enables the test...
	19. Type a name for your scenario. Click Next. The Finish screen opens.
	20. Check the box to Add scenario to current test. Click Finish. The name of your scenario should...

	Figure 7�5
	21. Click the Save icon on the Recovery Manager window to store the scenario you created as a .qr...
	22. Click Close.
	23. Stop the test run.


	Part 2: Run the Test and Analyze the Results
	Part 3: Create a Second Recovery Scenario
	1. If the test you created is not already displayed on your screen, find and open it by clicking ...
	2. Click Run. In the Run Results location tab, choose the option to save your test results to a t...
	3. Your test should fail during the third iteration. What error message appeared that stopped the...
	4. To anticipate and correct this error, click Tools > Recovery Scenario from the QuickTest menu ...
	5. Click the New Scenario wizard icon. Review the information on the Welcome screen then click Next.
	6. Select the trigger event that caused the error (Popup window), then click Next.
	7. To identify the name of the window where the error message appears, click the Pointing Hand ic...
	1. Move the Pointing Hand to the application login window then click once. The name of the window...

	2. Click Next to continue.The Recovery screen appears.
	3. You do not need to make any additions to this screen. Click Next. The second recovery scenario...
	4. Define the action that QuickTest should take if this error occurs during a test run by clickin...
	5. Move the Pointing Hand to the application window then click once on the Cancel button. The nam...
	6. Click Next. The Recovery Operations screen opens.
	7. De-select the option to add another recovery scenario then click Next.
	8. In the Test Options list, choose Proceed to the next step. This enables the test to move to th...
	9. Type a new name for this second scenario. Click Next. The Finish screen opens.
	10. Check the box to Add scenario to current test. Click Finish.

	Part 4: Check the Test Settings and Run the Test
	1. To make sure that both scenarios are linked to your test, click Test > Settings from the Quick...
	2. Click the Recovery tab.
	3. Check to make sure that two scenarios appear in the Recovery tab as shown in Figure�7�6. Use t...
	Figure 7�6
	4. Click OK.
	5. Click Run to playback the test. The test should succeed.




